CWE-SANS-Top-25/Risky-resource-management/CWE-129

From aldeid
Jump to navigation Jump to search

CWE-129: Improper Validation of Array Index

Description

This vulnerability mainly impacts C and Java based applications.

Incomplete.png
INCOMPLETE SECTION OR ARTICLE
This section/article is being written and is therefore not complete.
Thank you for your comprehension.

Risk measurement

Weakness Prevalence Common
Remediation Cost Low
Attack Frequency Sometimes
Consequences Code execution, Denial of service, Data loss
Ease of Detection Easy
Attacker Awareness Medium

Comments

Talk:CWE-SANS-Top-25/Risky-resource-management/CWE-129